Running Tomcat 5.5 on JDK 1.4 in Eclipse

For those running Tomcat 5.5 on a JDK 1.4, there will be compatibility issues. Testing it on Eclipse, the error would appear as such.

This release of Apache Tomcat was packaged to run on J2SE 5.0
or later. It can be run on earlier JVMs by downloading and
installing a compatibility package from the Apache Tomcat
binary download page.

This was what Eclipse would show if you came up with this error. Well, all one needs to do is to run the Tomcat on top a different Java Environment which is JDK 5 and above compliant.

Here’s how to do it.

On your Eclipse program go to Window > Preferences.

Server Environment Eclipse

Go to Server > Runtime Environments and select Apache Tomcat v5.5 and click Edit. Then you will proceed to this screen.

change server runtime environment eclipse

Under JRE, change it to another JRE, they have to be JDK6 or jre6. Do note, please install the latest JRE (Java Runtime Environment) or get the JDK 6 to add it in as a JRE beforehand.

Leave a Reply