Popularity Contest Plugin Fatal Error

Update April 16 2008 : I find that people are saying what is happening to their plugin even after they did what I did. Well, if you’re a first time setting up this plugin. Please do what was mentioned in Ken’s web. Anyway, for easier access, you can download the patched version of the plugin it directlyfrom Ken. Note you’ll still need to make the database changes if you don’t have the tables already in place.

Alex King’s wordpress plugin which goes by the name of Popularity Contest has the best popular post plugin. It gives a lot of information thus helping bloggers to judge what readers usually read. Well, sad to say, I did face an error when I converted my WordPress from 2.3 to 2.5. No error whatsoever at first, that was until I went and deactivate the popularity contest plugin.

The outcome?? After I tried to reactivate the plugin, it went bonkers and kept giving Fatal Error message. So off I go to search and found a help in Ken’s web. In his site, you can either download his latest patched file or rather you can just modify the popularity-contest.php and changed the following.

Open popularity-contest.php and scroll down to line 59.
Replace require(’../../wp-blog-header.php’); with require(’../wp-blog-header.php’);

This somehow solves my problem perfectly. So it tells me to be prepared for WordPress 2.5 compatibality issues.

4 Comments

  1. Ken McGuire April 15, 2008
  2. David April 16, 2008
  3. techieDan April 16, 2008
  4. ben April 16, 2008

Leave a Reply